The timeline seems to be reversed

Really struggling to understand the way the timeline works with staggered events.

If I input this:


Why do I get this in the inspector?

And if I input this


Why do I get this in the inspector?

It seems like the directions of these inputs are reversed?
It is not very clear what the first and what the second input field does. If I input 0 in the first field and 500 in the last field like so:

I get this:

I find this a little non-intuitive but that’s probably just my own twisted logic. Maybe someone can enlighten me?

Thanks!

The first field describes the length of the animation. In this case it starts at 0ms and animates for 500ms, the inspector show start and end-time, therefor 0 500.

Here the animation duration is again 500ms but it starts after a delay of 1000ms, the inspector show the start-time and end-time, here start is 1000ms (due to the delay) and the animation duration is 500ms.

animaton duration is 0, that means no animation at all, but the action should start after an delay of 500ms. (Does not really makes sense for an effect action…). Once again the inspector shows the start-time (500ms the delay) and the end-time (also 500ms because we do not animate)…

Sorry for the confusion, the text-fields (duration and delay) are described here https://www.antetype.com/docs/antetype-webpreview/interaction.html#_timinganimation. A tooltip is clearly missing :thinking:

Does this make sense?

It does make sense but I find it hard to grasp from the way the UI communicates it. Don’t worry about it. As long as I am the only one, it will be fine. What I was trying to achieve is the brief flash that you get when you select a menu item on macOS:
Flash
The challenge is to have it flash at the right speed and then close the whole menu after the item has flashed.